Решение проблем с установкой NET.Framework 3.5 SP1

Суть проблемы

При установке очередного обновления NET.Framework 3.5
возникает сообщение:

Данная ошибка наблюдается на Windows XP SP3 (OEM) и Windows Server 2003 SP2 (EE).

Причина
Вероятнее всего, имеет место ошибка инсталлятора, неправильно определяющего версии обновлений.

Решение
1. Убедитесь, что ваш дистрибутив соответствует описанию:

.NET Framework 3.5 Setup
3.5.30729.01
dotnetfx35.exe
231 МБ (242 743 296 байт)

В случае необходимости, можно скачать NET Framework 3.5 SP1

2. Удалите любое из найденных обновлений с версиями:

Microsoft NET.Framework 2.0
Microsoft NET.Framework 2.0 Service Pack 1
Microsoft NET.Framework 2.0 Service Pack 2
Microsoft NET.Framework 3.0 Service Pack 1
Microsoft NET.Framework 3.0 Service Pack 2
Microsoft NET.Framework 3.5

Как это сделать: Пуск => Панель управления => Установка и удаление программ => Изменение или удаление программ.

В случае неудачи используйте DotNetFx Cleanup Tool

После выполнения данных действий запустите установку NET.Framework 3.5 SP1 ещё раз и следуйте указаниям инсталлятора.

Так же вам может понадобиться скачать NET Framework 4

Рубрика: 

Комментарии

Марат
Спасибо автору - удаление предыдущих версий помогло


Vollariss
Если делать всё по инструкции, проблем не взникает.
Огромная благодарность авторам и мой respect!


Эдуард
Проблема не решена!
Удалите любое из найденных обновлений ...В случае неудачи используйте DotNetFx Cleanup Tool - DotNetFx Cleanup Tool не удалила обновления.


admin
Эдуард, перезагрузиться не помешает после каждой манипуляции. Пробовали?
Так же попробуйте перекачать по-новой файл dotnetfx_cleanup_tool, он обновился.


Сергей
Вот еще хорошая статья, три способа решения проблем с установкой NET Framework

http://net-framework.ru/


Читать обсуждение полностью...



Добавить коментарий